Tag Archives: Codelite

C++ Demo of finance chart with wxWidgets CodeLite wxCrafter

C++ Demo of finance chart with wxWidgets CodeLite wxCrafter

The easiest way to display static trading charts

Join my FREE newsletter to learn more C++ tricks for automated trading

 

NOTE I now post my TRADING ALERTS into my personal FACEBOOK ACCOUNT and TWITTER. Don't worry as I don't post stupid cat videos or what I eat!

Demo of wxWidgets wxCrafter CodeLite C++ on Ubuntu Linux

Demo of wxWidgets wxCrafter CodeLite C++ on Ubuntu Linux

Getting familiar with this tool. Note that this really works only on Linux with wierd problems on Mac OSX

Join my FREE newsletter to see how I use these tools for my automated trading

 

NOTE I now post my TRADING ALERTS into my personal FACEBOOK ACCOUNT and TWITTER. Don't worry as I don't post stupid cat videos or what I eat!

Tips to build wxWidgets C++ for Ubuntu Linux with Codelite IDE

Tips to build wxWidgets C++ for Ubuntu Linux

Here are some notes to help 


https://www.wxwidgets.org/downloads/
../configure --enable-unicode --enable-debug

configure: error: 
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

You may need to do: 
apt-get install libgtk2.0-common
http://forums.mozillazine.org/viewtopic.php?f=6&t=113419

Also, edit your Ubuntu bash profile
http://ubuntuforums.org/showthread.php?t=1707261
vim ~/.bashrc

Add your GTK library to LD_LIBRARY_PATH 
http://www.mathematik.uni-ulm.de/help/gtk+-1.1.3/gtkfaq-2.html

ALso, try installing with as this worked for me:
apt-get install libgtk2.0-dev

Install java 8
sudo add-apt-repository ppa:webupd8team/java
$ sudo apt-get update
$ sudo apt-get install oracle-java8-installer
http://tecadmin.net/install-oracle-java-8-jdk-8-ubuntu-via-ppa/#

I had serious issues with configuring Netbeans and Eclipse IDEs for wxWidgets, but it 
seems CodeLite IDE has preconfigured settings for wxWidgets. 

http://askubuntu.com/questions/330268/how-to-install-codelite-on-ubuntu

sudo apt-key adv --fetch-keys http://repos.codelite.org/CodeLite.asc
sudo apt-add-repository "deb http://repos.codelite.org/ubuntu/ $(lsb_release -sc) universe"
sudo apt-get update
sudo apt-get install codelite wxcrafter

This link maybe useful as well http://www.tarsiersoft.com/addinfo/wxWidgetsInstall.php
 Join my FREE newsletter to learn more how wxWidgets  will help my automated trading 

NOTE I now post my TRADING ALERTS into my personal FACEBOOK ACCOUNT and TWITTER. Don't worry as I don't post stupid cat videos or what I eat!