Joomla has a horrible upgrade process from 1 to 1.5!!

Joomla has a horrible upgrade process from 1 to 1.5!!