Tag Archives: yum

Script for RStudio CentOS Linux install dependencies yum

 

Script for RStudio CentOS Linux install dependencies yum

This is supposed to work:

http://support.rstudio.org/help/discussions/problems/3353-installing-r-studio-server-on-redhat-446-4#comment_18902730
yum install r-studio-server.rpm

https://github.com/rstudio/rstudio/blob/master/dependencies/linux/install-dependencies-yum

 

#!/bin/bash
#
# install-dependencies-yum
#
# Copyright (C) 2009-12 by RStudio, Inc.
#
# This program is licensed to you under the terms of version 3 of the
# GNU Affero General Public License. This program is distributed WITHOUT
# ANY EXPRESS OR IMPLIED WARRANTY, INCLUDING THOSE OF NON-INFRINGEMENT,
# MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Please refer to the
# AGPL (http://www.gnu.org/licenses/agpl-3.0.txt) for more details.
#
#
set -e
# build/development tools
sudo yum install -y make
sudo yum install -y gcc
sudo yum install -y gcc-c++
sudo yum install -y cmake
sudo yum install -y rpmdevtools
# core system libraries
sudo yum install -y libuuid-devel
sudo yum install -y openssl-devel
sudo yum install -y bzip2-devel
sudo yum install -y zlib-devel
sudo yum install -y pam-devel
# boost
sudo yum install -y boost-devel
# pango cairo
sudo yum install -y pango-devel
# gwt prereqs
sudo yum install -y java-1.6.0-openjdk
sudo yum install -y ant
sudo yum install -y xml-commons-apis
# common
cd ../common
./install-gwt
./install-dictionaries
./install-mathjax
cd ../linux
# boost
./install-boost
# desktop dependencies (qt)
if [ “$1” != “–exclude-qt-sdk” ]
then
   # install Qt 4.8 SDK (into a private /opt/RStudio-QtSDK directory so as to
   # not conflict with any other installed versions of Qt on the system)
   ./install-qt-sdk
fi